BALANCEaap > Data > Advanced > Batch Operations

KEY TOPICS:

In the numbered steps below —

  • Select Plans
  • Select Tables
  • Establish Connections
  • Determine Table Filters
  • View Results
  • Perform Batch Operation


Globally Update, Delete, or Export Data

The wizard at Data > Advanced > Batch Operations guides you through the process of tailoring a batch operation for specific data needs. The operation's six steps are explained below.

1. Plans

Answer the question: Are you going to use data from outside this plan?

To include another plan, select: Yes; or to limit the operation to the current plan, select: No.

If Yes was chosen, select the Company, Establishment, and Plan from the drop-down.

Click [Next] to continue.

2. Tables

Select one or more Tables to include in the batch operation.

If data from the current and an additional plan are being used, the tables from the current plan will be displayed first, followed by the tables from the additional plan. Select a table from the current plan (and, if applicable, an additional plan). The selections will be used to populate the menus you will use in the next steps.

Click [Next] once you have made the selections.

3. Connections

Connections are created across two or more tables, using fields. Up to five connections may be created.

Note: BALANCEaap will display default connections. Tools will appear where you can determine connections. If you proceed without determining a connection, logical connections will be attempted by the system.

[Expand] the Add Connection menu by clicking the header; and choose Table and Field. If you have chosen to use data from another plan, choose Current Plan or Additional Plan to view the corresponding tables. Click [Save Connection] once selections are made.

The Connection will be added to the Current Connections list. To remove a Connection from the list, click the check box for the corresponding connection, and then click [Delete Connection].

4. Filters

Create a filter that will limit the data to be used in the operation, based on specific criteria. Up to five fields may be created. From the Add Filter menu, select Table and Field from the drop-downs. If you are using data from another plan, choose Current Plan or Additional Plan to view corresponding tables and fields.

From the center column drop-down, choose an operator:

  • Equal To
  • Not Equal To
  • Less Than
  • Less Than or Equal To
  • Greater Than
  • Greater Than or Equal To
  • Contains^
  • Does Not Contain^

^For these two operators, the system can filter on an underscore, a percent symbol, or square brackets to make batch corrections for those symbols.

Using the right-hand column, choose a value, either:

  • Specific Value — A word, phrase, number, or other data found in the selected Table and Field. (Most Batch Operations are performed with this filter option.)
  • OR

  • Value From Another Field— Select a table and field from the Current Plan (or the Additional Plan, if applicable).

Click [Add FIlter]. Any created Filters will display within the Current Filters menu. Finally, check off the filter(s) for inclusion in the operation.

Quick Tip: To remove a filter from the Current Filter list, select it and click [Delete Filter].

Indicate how the conditions in the filter should be used, either:

  • All of the following conditions must be true
  • OR

  • Only one of the following conditions must be true

Click [Next].

5. Results

The Results will display in table format for review. If data from two plans are displayed, the fields will be color coded, accordingly.

If the Results are not what were expected, click [Previous] to review and edit previous options.

If the Results are correct, select an operation to be executed in Step 6:

  • Export the results to a file
  • Delete data from this plan based on the results
  • Update data in this plan based on the results

Click [Next].

6. Operation

Based on the operation chosen in Step 5 (above), follow the guided prompts. To continue with:

  • Exporting data — Select a file type; then click [Export Results].
  • Deleting data — Select the table from which the records should be deleted. Click [Delete Data].
  • Updating data — Choose the Table and Field to update. Then select one of the following options:
    • Specific Value
    • Update from another field — Choose a Table and Field from the Current Plan or Additional Plan.
    • Manipulate Current Value — Change the case of the value, or trim spaces from the beginning or end of the value.

Click [Next] and [Update] to perform the update via batch operation.