BalanceWORKS Browser Support Policy

Last Updated: April, 20, 2021

RETURN TO: Product Release Notes Index


Supported Browsers

Berkshire is committed to developing browser-agnostic Web applications that will work on a variety of browsers and platforms beyond those listed below. The user interface is built, using only HTML, CSS, and JavaScript, and following current standards for each of these languages. Evolving security standards, the ability to stay current with these standards, as well as performance improvements made available in modern browsers, however, require Berkshire to support a limited number of platforms.


Browser Policy

Effective July 1, 2021, new releases of balanceWORKS software will be designed and tested to run on the following browsers:

  • Microsoft Edge - Current version and immediately prior version
  • Firefox – Current version and immediately prior version
  • Google Chrome – Current version and immediately prior version

Cookies

BalanceWORKS uses session cookies, which requires cookies to be enabled in the user’s browser. Third-party cookies are not required and can be disabled, if desired.

JavaScript

JavaScript must be enabled on any browsers that connect to balanceWORKS.

Browser Plugins and Extensions

BalanceWORKS does not require any browser extensions or plug-ins for normal use. BalanceWORKS applications can optionally display reports in PDF, which may require a PDF plug-in, depending on your browser.

Security

All Berkshire applications currently support TLS 1.2 only. Browsers not supporting these TLS versions will be unable to connect to balanceWORKS. Berkshire does NOT support TLS 1.0 ,TLS 1.1, SSL 2.0, or SSL 3.0.

Note: For more information about browsers that support TLS 1.2, please visit this Website.

Unsupported Browsers

Other browsers not supported by Berkshire may still work with balanceWORKS if they meet the Cookie, JavaScript, and Security requirements above. With these browsers, there may be issues with the display of the user interface, or some functionality relying on JavaScript may be limited. Browsers that do not meet the security standards above will not be able to connect to balanceWORKS.

In the event you are having an issue with balanceWORKS in an unsupported browser, you may contact Berkshire’s Product Support to report the issue. If the Product Support team determines the issue is browser related, they will recommend moving to a supported browser.